0

Excel : Identifier et extraire le domaine et sous domaine d’une URL

Vous voilà avec une liste d’URL, et vous souhaitez savoir si ces URL se situent sur un domaine ou sous domaine. Pour cela, utilisons la formule suivante :


=SI(ET(NBCAR(E2)-NBCAR(SUBSTITUE(E2;".";))=2; ESTERR(CHERCHE("www";E2)<>1));"sous domaine";"pas sous domaine")

 

Ensuite, pour extraire le sous domaine utilisons :


=RegexpFind(D2;"https?:\/\/([^/]*)";1)

 

Et enfin pour le domaine :


=RegexpFind(E2;"([^\.]+\.[^\.]+$)";1)

excel-extraire-sous-domaine

 

 

marseo

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *